Trouble On Mac

Sep 9, 2008 at 9:08 AM
Let me start by saying you've done a great job on this app! (saved me a lot time!)

I'm fairly new to .NET and I just setup a test page with your sample code for the S3 upload.
I did not customize anything I left the code exactly the way it was in the sample I got from your site.

Everything seems to be working fine on all browsers when I'm testing from my PC, but when I test it from safari on the Mac the progress bar seems to get stuck on the first file on the list and will not update.

The strange thing is that if I visit the demo page on your server (from my Mac) then your sample code runs perfectly!
http://www.flajaxian.com/flajaxian.com/docs/default.aspx#demo

I just don't get it???? Is that sample code running on your server somehow different than what I have?
Is your server configured differently?

Also, when testing with a file that has an "&" in the name it fails on my demo page. (both PC and Mac)
But once again - It works perfect from your demo page!
Is it possible to somehow rename or strip out characters from the file that is being uploaded?

What am I missing?
I'm pulling my hair out over here!!! :)

I know I left the sample code untouched, but somehow your demo page runs fine on Mac and mine doesn't.

Thanks in advance.


Here is the sample code I'm running....

<%@ Register TagPrefix="fjx" Namespace="com.flajaxian" Assembly="com.flajaxian.FileUploader" %>
<%@ Register TagPrefix="fjxau" Namespace="com.flajaxian.AWS" Assembly="com.flajaxian.AmazonUploader" %>

<form id="form" runat="server">

<fjx:FileUploader ID="FileUploader1" runat="server" >
    <Adapters>
        <fjxau:AmazonUploader
                AccessKey="WebConfig:AmazonAccessKey"
                SecretKey="WebConfig:AmazonSecretKey"
                BucketName="testbucket">
                    <AccessControlList>
                        <fjxau:AccessControl URI="http://acs.amazonaws.com/groups/global/AllUsers" Permission="READ" />
                    </AccessControlList>
            </fjxau:AmazonUploader>
    </Adapters>
</fjx:FileUploader>

  <appSettings>
    <add key="AmazonAccessKey" value="XXXXXXXXXXXXX" />
    <add key="AmazonSecretKey" value="XXXXXXXXXXXXXXXXXXXXXXXXX" />
  </appSettings>

</form>





Coordinator
Sep 10, 2008 at 3:58 AM
Edited Sep 10, 2008 at 4:02 AM
Hi JPSalva,

So the stacking issue is the same discussed in the previous Flajaxian S3 Amazon forum topic http://www.codeplex.com/FlajaxianS3Upload/Thread/View.aspx?ThreadId=34891. You only see this when you try it on your local host. Flash mesures only the progres of the Flash - Server transfer which is quick on localhost but not Server - Amazon. In real server application you won't see this and this is why the problem is not visible on the demo.

So upload your control on a remote server and try it there.

The & character was really a problem and it was fixed in the latest version. Please get the latest source or binaries from the Release folder.

Let me know if you see problems on MAC when you upload your control on a server. If so on what browser?

Thank you for your feedback.
Coordinator
Sep 10, 2008 at 4:03 AM
And by the way the demo page is for just Upload not Amazon upload so if the issue is Amazon related like & character you won't see it on the demo.
Feb 24, 2012 at 2:17 PM

Hi Flajaxian Coordinator --

We're experiencing a similar problem as JPSalva on mac OS10.7.2 on both safari and chrome.

the progress bar seems to get stuck on the first file on the list and will not update.


We're using the Direct to S3 Uploader and it's deployed on a server.