Mar 25, 2008 at 12:57 PM
Hi thanks for a great control.

I'm having difficulties uploading files when I have configured membership authentication. If I'm logged in as a user, the uploader will give me an IOError in debug mode. If I'm not logged in (ie anonymous) it works as expected. I've googled around for a day now about granting io permissions to users etc but I'm starting to wonder if there's anything to do with the upload control.

Mar 26, 2008 at 5:44 PM
Yes the component cannot change the permission for the folders you use to upload. You have to do it on the server.
Mar 26, 2008 at 7:51 PM
Thing is, the control doesnt even get to the point where the adapter saves the file to the disk. It gets an io error before processfile is called. It saves the file in memory yes? Not temporarily on the drive somewhere.. So the folder rights shouldnt be an issue (i set permissions and still get the error). So must be a POST permission issue or something? Tried allowing POST in web.config for everyone without success.

This also only occurs when I've logged in via my web site app and membership forms authentication. Ideas?

Mar 27, 2008 at 12:13 AM
If you submit the error stack trace may be I can tell you more.
Mar 28, 2008 at 6:28 PM
Well I got it working in IE7 somehow, but the error remains in FF2. Seems like it's writing the first buffer bytes but then stops when trying to flush the buffer for some reason?

FileUploader.onSelect #Files:1
FileUploader.upload 1
FileUploader.onOpen001_Michael Land - Monkey Island 3.mp3
FileUploader.onProgress current file - bytes current file: 65536 of 2539624 or total 65536 of 2539624
FileUploader.onIOError: 001_Michael Land - Monkey Island 3.mp3
Apr 2, 2008 at 6:26 AM
It sounds strange and my best guess is that it interacts with some of your code but it's hard to say without seeing it. Interesting if anyone else has seen this bug?

If you can email me an example of the problem (just the problem demonstration) I could tell you more.